Help Center

Powered by Minitek FAQ Book
Loading...

PHP type error on Minitek Wall Pro and Minitek Slider Pro

BB
Bruce ButtonPosted 3 months ago
Joomla! Extensions - Professional Subscription

When trying to access the Widgets (either by clicking on an existing widget or trying to create a new one) in Wall Pro and Slider Pro I get this error:

0 Joomla\Component\MinitekWall\Administrator\Table\WidgetTable::__construct(): Argument #1 ($db) must be of type JDatabaseDriver, Joomla\Database\Mysqli\MysqliDriver given, called in /home/imago-home.co.za/public_html/ie/j5t/libraries/src/MVC/Factory/MVCFactory.php on line 274 

I see that another person asked a similar question, to which the answer was that the extension would be updated to Joomla 5 during November.

Is this just a Joomla 5 issue, or is it something else? I am using Joomla 5.0.1 with the backward compatibility plugin. I was under the impression that the backward compatibility plugin would allow Joomla 4 extensions to work on Joomla 5 without a problem.

I would be most grateful for a solution to this problem. I have just renewed my subscription to Minitek and this is the time of the year when I really am able to work on my business's website. It is quite urgent for me to be able to move ahead with this. I am using the Minitek slider for the main banner of my website, so it really is important to be able to access this widget.

Thank you for your assistance.

Kind regards
Bruce

Loading...
0
#4150

6 answers

M
MinitekPosted 3 months agoModerator

Hi Bruce,

Yes, this is a Joomla 5 compatibility issue. I will try to have the Minitek Wall Pro version ready by tonight. The Minitek Slider Pro will follow next week.

BB
Bruce ButtonPosted 3 months ago

Thank you for the reply.

I really would appreciate an update to these two extenstions as soon as possible.

 

Best regards
Bruce

BB
Bruce ButtonPosted 2 months ago

I am getting this error when trying to edit a widget in Minitek Slidre Pro:

 

An error has occurred.
0 Joomla\Component\MinitekSlider\Administrator\Table\WidgetTable::__construct(): Argument #1 ($db) must be of type JDatabaseDriver, Joomla\Database\Mysqli\MysqliDriver given, called in C:\wamp64\www\j5t\libraries\src\MVC\Factory\MVCFactory.php on line 274

 

It seems as though this component still needs to be updated to Joomla 5. I would appreciate an update as soon as possible. I am using this component for the main banner on my website and need to edit it.

 

Best regards
Bruce

M
MinitekPosted 2 months agoModerator

Hello,

Minitek Slider is not yet compatible with Joomla 5.

BB
Bruce ButtonPosted 2 months ago

Can you give me an idea when Minitek Slider will be updated to Joomla 5?

I need to know whether I need to find another extension to replace Minitek Slider, or whether I can wait long enough for the Minitek extension to be updated.

Thank you.

M
MinitekPosted 2 months agoModerator

It will be released on January.