Module doesn't work

CB
Christoph BurkhardPosted 2 years agoEdited 2 years ago
Hi
So. I purchased the Module last year but i haven't succeed to make it work.
For a specific Project i wanted to give your extensions another try.
But still the same. I can't see any content, nor images.

Thank you
Christoph
0
#2148

8 answers

CB
Christoph BurkhardPosted 2 years ago
Hi

It seems it's a javascript error caused by the shaper_helix3 Template.
The strange this is, all other extensions (widgetgit, Sp pagebuilder and so on) work normal. Except the minitek Extension.

Maybe you have a solution?
Thank you

Best regards

Christoph
Y
YannisPosted 2 years agoModerator
Hi Christoph,

That's because there are javascript pages present in your website.
Did you check for javascript errors before enabling the extension?
https://www.minitek.gr/support/documentation/frequently-asked-questions/joomla-extensions/my-website-has-existing-javascript-errors-what-can-i-do
CB
Christoph BurkhardPosted 2 years agoEdited 2 years ago
Hi Yannis

Yes, i saw it. There's a Java-Script Error. But how to fix it?
And why do all other extensions work except the minitek module?
You can find java-script errors on so many Websites, even on a google.com site.
Check your own minitek.gr Site and what can you find? Some Java-Script Errors ;-)

Thanks for Helping
Christoph

Y
YannisPosted 2 years agoModerator
On our website there are no javascript errors. If you found one, let me know and I'll fix it asap.

Unfortunately there is no workaround for that. Errors are errors and they break stuff.
Yes, some extensions may work with errors. But others will not work. Especially the more complicated ones.

The only solution is to find the extension (or script) that creates the error and either disable it or fix it.

Javascript errors will create all sorts of weird behaviour in extensions. It may look like an extension is working, when in reality it's not working as expected and opens up ways for hackers to inject stuff in your site.
Y
YannisPosted 2 years agoModerator
The error is in the following code of your template:

jQuery('html, body').animate({
scrollTop: jQuery(hash).offset().top 80
}, 800, function(){
...
...


Notice the "80" number above. That is a mistake and must be removed.
The code should be:
jQuery('html, body').animate({
scrollTop: jQuery(hash).offset().top
}, 800, function(){
...
...
Y
YannisPosted 2 years agoModerator
PS. The above code is used for the smooth scrolling of links in your template.
CB
Christoph BurkhardPosted 2 years ago
Hi Yannis

That was the Point. Thank You.
Now it works ...

BTW: This is the Java Script Error on your Site

Best regards
Christoph
Y
YannisPosted 2 years agoModerator
That's great. :)


I can't see the error on my end. Are you using any ad blocker in your browser?
Sometimes the ad blockers break stuff in websites.

Search