Help Center

Powered by Minitek FAQ Book

Request-URI Too Long

LD
Luca De MatteisPosted 5 months ago

Hi there

when i try to make some search, i've got this error so many times:

Request-URI Too Long

The requested URL's length exceeds the capacity limit for this server.

Additionally, a 414 Request-URI Too Long error was encountered while trying to use an ErrorDocument to handle the request.

 

The url in the address bar is soooooooooooooooooo long!!

How to manage this?

I need to fix it

 

Thanks

Loading...
0
#3448

15 answers

LD
Luca De MatteisPosted 5 months agoEdited 5 months ago

Any news?

I've got a result URL like this one:

URL

So there a enormous string append to the original URL and i've got this error.

Highlight search terms option is setted to NO...

How can i fix it?

M
MinitekPosted 5 months agoModerator

How did you produce this long url? From a search result?

Please send me a link where I can see the search bar and the search results.

I also need admin access so that I can check the component configuration.

LD
Luca De MatteisPosted 5 months ago

You can check my website but you have to add these lines to your Hosts files:

185.81.4.100 vinileshop.it

185.81.4.100 www.vinileshop.it

Check here: http://www.vinileshop.it/vinili/

and try to make a search in the top right by searching something like "Fabrizio De André" or sort of.

Admin credentials are:

url: http://www.vinileshop.it/vinili/administrator

login: demaluca1980!

password: Rimediotti74!

Please update, thanks!

LD
Luca De MatteisPosted 5 months ago

Any news?

M
MinitekPosted 5 months agoModerator

That page does not display Minitek Live Search.

This is the default Joomla search, not Minitek Live Search.

LD
Luca De MatteisPosted 5 months ago

That's because you didn't changed your hosts file, or you did it wrong :)

You're watching the old website

You have to add these lines to your Hosts files:

Then, reload the URL and check here: http://www.vinileshop.it/vinili/

Please update, thanks

M
MinitekPosted 5 months agoEdited 5 months agoModerator

Indeed, there is an issue with the highlight="..." part of the url added even when Highlight search terms is disabled. I will fix this in next update.

LD
Luca De MatteisPosted 5 months ago

Thanks a lot

Please update me when ready so i can renew and update the plugin!

M
MinitekPosted 5 months agoModerator

Hi there,

This fix has already been included in the next version (will be released in a couple of weeks).

For now, you can fix it by disabling the parameter

Global configuration > Smart search > Highlight Search Terms

LD
Luca De MatteisPosted 5 months ago

Already done, but it doesn't works...

M
MinitekPosted 5 months agoModerator

Which parameter did you disable?

M
MinitekPosted 5 months agoEdited 5 months agoModerator

There are 2 separate parameters:

Global config > SMART SEARCH > Highlight search terms


and


Global config > MINITEK LIVE SEARCH > Highlight search terms


Are you 100% certain that you disabled the 1st one too?

LD
Luca De MatteisPosted 5 months ago

I've disabled into component options

COMPONENT > MINITEK LIVE SEARCH > CONFIGURATION

There's no smart search into Global Config in Joomla

PS: this editor can't allow attachments...

M
MinitekPosted 5 months agoModerator

See attached image

LD
Luca De MatteisPosted 5 months ago

Solved, thanks